Надо составить программу для паскаль abc дано вещественное число.если оно отрицательное, вывести на экран его модуль, а если нет, то вычислить из него квадратный корень.

Артёмка110 Артёмка110    1   18.03.2019 00:40    5

Ответы
Eva5768 Eva5768  25.05.2020 21:54

var

  a: real; 

 

begin

  writeln('Введите вещественное число');

  readln(a);  //Вводим вещественное число

  if a < 0 then writeln('Модуль числа а: ', abs(a))  {Если введенное число - отрицательное, печатаем его модуль, иначе печатаем квадратный корень из этого числа с округлением до 5 знаков после запятой}

  else writeln('Квадратный корень из числа а: ', sqrt(a) : 0 : 5);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика