tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
надо составить программу.
надо составить программу. 1)у наибольшего из чисел x,y,z найти цифру младшего разряда(единиц) и остаток от его деления на 3. 2)написать программу,которая по номеру дня недели выдаёт количество уроков на следующий день.
ynal2001
2 10.07.2019 17:40
2
Ответы
hychkairyna
17.09.2020 13:56
2. var n: Integer;
Begin
readln(n);
write('Уроков ');
case n of
1: writeln('6');
2: writeln('6');
3: writeln('6');
4: writeln('5');
5: writeln('5');
6: writeln('нет');
7: writeln('6');
end;
End.
ПОКАЗАТЬ ОТВЕТЫ
thefizrap0c5s5
17.09.2020 13:56
Согласно первому заданию надо сначала найти максимальный элемент
uses crt;
var x,y,z,max:integer;
Begin
writeln('Введите x y z');
readln(x,y,z);
if (x>y) and (x>z)
then max:=x
else
if (y>x) and (y>z)
then max:=y
else max:=z;
Writeln('max =',max);
Writeln('Младший разряд =',max mod 10);
Writeln('Остаток от деления на 3 =',(max mod 10) mod 3);
readln;
end.
2)
var n: Integer;
Begin
writeln('Введите день недели');
readln(n);
write('Уроков ');
case n of
1-4: writeln('6');
5,6: writeln('5');
7: writeln('нет');
end;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Anyazz
11.07.2019 02:30
Глобус является а) образной б) знаковой в) смешанной г) натурной...
DyxaK
11.07.2019 02:30
Записать высказывание на языке логики идёт спектакль или не спектакль и кто -то не выключил душ...
aannaa2
11.07.2019 02:30
Выполните операцию сложения над двоичными числама 1011+100...
sanjabr82oymx7f
30.05.2019 08:40
Название каких струнных инструментов напоминает о красивых цветах?...
Krank09
30.05.2019 08:40
Заполнить массив 5 целыми числами с клавиатуры и вывести их в строку в обратном порядке....
homya4okm
30.05.2019 08:40
Полное имя файла с: \8 класс\петров пётр\самостоятелная работа\самраб.doc в каком файле хранится файл самраб.doc...
ЦветокЛотоса
30.05.2019 08:40
Вчем смысл магистрально-модульного принципа построение компьютера?...
irochka320969
22.11.2020 16:32
Не себепті роботтар тірі организм принципі бойынша құрастырылады?...
ОльгаГалюткина
22.11.2020 16:31
Оперативная память компьютера составляет 512Мб. Сколько страниц текста можно разместить в памяти этого компьютера ( на странице размещается 40 строк по 60 символов в каждой строке,...
ffoxyyyy1
03.10.2019 13:45
Все 5- буквенные слова, составлены из букв а, г, ж, х, к записаны в алфавитном порядке. вот начало списка: 1. 2. 3. 4. 5. 6. 7. 2.1 укажите номер первого слова, которое начинается...
Популярные вопросы
найдите область определения функции y=log3(5x-1)...
2
Тұздардың құрамындағы кальций мен магний массалық үлесі...
1
Привет по англ. яз. 4 класс рабочая тетрадь Brilliant стр 67 номер 2 и стр 68 номер...
2
Доберіть дієслова,синонімічні щодо поняття творити добро (наприклад...любити,співчувати)...
1
И.А. Бунин «Господин из Сан-Франциско» 1. Почему у главного героя рассказа нет имени?...
1
Отзыв о рассказе Э. Вильде «Их сын» Расскажите, какое впечатление произвело на вас...
1
Накресліть вектори KC і КD, їхні суму та різницю....
2
РЕШИТЬ ЗАДАНИЕ НЕ ИГНОРИРУЙТЕ...
2
Кто при Козленка отбиться от волков?...
3
Во по произведениям «единородный сыне» и «херувимская песнь» Какова роль церковного...
1
Begin
readln(n);
write('Уроков ');
case n of
1: writeln('6');
2: writeln('6');
3: writeln('6');
4: writeln('5');
5: writeln('5');
6: writeln('нет');
7: writeln('6');
end;
End.
uses crt;
var x,y,z,max:integer;
Begin
writeln('Введите x y z');
readln(x,y,z);
if (x>y) and (x>z)
then max:=x
else
if (y>x) and (y>z)
then max:=y
else max:=z;
Writeln('max =',max);
Writeln('Младший разряд =',max mod 10);
Writeln('Остаток от деления на 3 =',(max mod 10) mod 3);
readln;
end.
2)
var n: Integer;
Begin
writeln('Введите день недели');
readln(n);
write('Уроков ');
case n of
1-4: writeln('6');
5,6: writeln('5');
7: writeln('нет');
end;
End.