Надо сдать! написать программу на языке с++ дана последовательность n различных целых чисел. найти сумму ее членов,расположенных между максимальным и минимальным значениями(в сумму включить и оба этих числа).

Karta2346574 Karta2346574    3   09.09.2019 13:00    3

Ответы
КаринаХасанова9 КаринаХасанова9  07.10.2020 03:11
#include <iostream>
using namespace std;
int main()
{
 int n,max, min, pos1, pos2, mem, sum;
cin >> n;
pos1 = 0;
pos2 = 0;
int *A = new int[n];
for (int i = 0; i < n; i++)
{
 cin >> A[i];
}
min = A[0];
max = A[0];
for (int i = 0; i < n; i++)
 {
 if (A[i] > max)
 {
  max = A[i];
  pos1 = i;
 }
 if (A[i] < min)
 {
  min = A[i];
  pos2 = i;
 }
}
if (pos2 > pos1)
{
 mem = pos2;
 pos2 = pos1;
 pos1 = mem;
}
sum = 0;
for (pos2; pos2 <= pos1; pos2++)
{
 sum = sum + A[pos2];
}
cout << sum;
system("pause");
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика