Надо сдать эти работы! 60 ! написать все программы на языке с++ 1) в массиве в(11) все элементы из интервала (a,b) занесите в массив с и найдите сумму элементов полученного массива. 2) написать программу, которая по вводимому числу от 1 до 11 ( номер класса) выдает соответствующее сообщение " k-классник". например k=1 " первоклассник", если k=4 " четвероклассник. 3) дано число х. напечатать в порядке возрастания числа sin(x), cos(x), ln(x). если при каком-либо х некоторые из выражений не имеют смысла, вывести об этом сообщение и сравнивать значения только тех, которые имеют смысл."

sidikreal sidikreal    3   07.09.2019 00:00    5

Ответы
Вторая:
#include <iostream>
using namespace std;
int main(){    setlocale(LC_ALL, "Russian");
    int form;    cin >> form;    string sForm[11] = {        "первоклассник","второклассник","третьеклассник","четвероклассник","пятиклассник",        "шестиклассник","семиклассник","восьмиклассник","девятиклассник","десятиклассник",        "одиннадцатиклассник"    };    cout << "Привет, " << sForm[form-1];    return 0;}

Первая:
Не совсем понятно условие - ввода для заполнения массива B нет. Поэтому пишу лишь основную часть кода.
int sum = 0;
for(int i=0;i<b-a;i++){
        C[i] = B[a+i];
        sum += B[a+i];
}

Третья:
#include <iostream>#include <cmath>
using namespace std;
int main(){    int x;    cin >> x;    double result[3];    result[0] = sin(x);    result[1] = cos(x);    result[2] = log(x);    bool finished = false;    while(!finished){        finished = true;        for(int i=0;i<2;i++){            if(result[i] < result[i+1]){                int buf = result[i];                result[i] = result[i+1];                result[i+1] = buf;                finished = false;            }        }    }    for(int i=0;i<3;i++){        if(result[i] == result[i] && abs(result[i]) != HUGE_VAL)        cout << result[i] << endl;    }    return 0;}

Примечание к коду: result[i] == result[i] - это проверка, является ли число неопределенным.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика