Надо написать программу, определяющую сколько слов в тексте начинается на букву "а". (паскаль)

Матвей2048602 Матвей2048602    1   07.12.2019 21:44    4

Ответы
dfhdfhf20022004 dfhdfhf20022004  10.10.2020 19:12

uses crt;

var  st,buf:string;

k:integer;

begin

k:=0;

clrscr;

write('-> ');

readln(st);

repeat

 if (st[1]=' ') or (length(st)=0) then while st[1]=' ' do delete(st,1,1)

 else

 begin

  while (st[1]<>' ') and (length(st)>0) do

  begin

   buf:=buf+st[1];

   delete(st,1,1);

  end;

 if upcase(buf[1])='A' then inc(k);

 buf:='';

 end;

until (length(st)=0) and (length(buf)=0);

writeln(k);

readln;

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
sofirzhk sofirzhk  10.10.2020 19:12

Program bykvaa;

Uses crt;

Var  

a:string;

b,i:integer;

begin

writeln('Введите текст:');

readln(a);

if a[1]='а' then b:=b+1;

for i:=2 to length(a) do

begin

 if a[i]='а' then if a[i-1]=' ' then b:=b+1;

end;

writeln('Количество слов в тексте, начинающихся на букву "а": ',b);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы