Надо написать программу определяющую характеристику произвольного числа введённого через клавиатуру.

Футболист111111 Футболист111111    2   18.03.2019 09:11    4

Ответы
Xela936 Xela936  25.05.2020 22:53

var a:integer;

begin

write('Введите произвольное число'); readln(а);

if a = 0 then begin

writeln ('Введен нуль');

exit;

end;

if а > 0 then writeln ('Число положительное');

else writeln ('Число отрицательное');

if a mod 2 = 0 then writeln('Число четное');

if a mod 3 = 0 then writeln('Число кратно 3');

if a mod 5 = 0 then writeln('Число кратно 5');

if a mod 7 = 0 then writeln('Число кратно 7');

if a mod 9 = 0 then writeln('Число кратно 9');

if a mod 10 = 0 then writeln('Число кратно 10');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика