надо! Информатика паскаль 9класс.напишите программу к задаче : Массив состоящий из шести элементов задан на интервале [0, 18) с датчика случайных чисел . Найдите сумму элементов массива и среднее арифметическое элементов массива.​

Zacloock Zacloock    2   25.01.2021 19:06    8

Ответы
кирилл2124 кирилл2124  24.02.2021 20:09

program z1;

var a:array [1..6] of integer;

i,s:integer;

begin

s:=0;

randomize;

write ('Массив: ');

for i:= 1 to 6 do

begin

a[i]:=random(18);

write(a[i],'  ');

s:=s+a[i]

end;

writeln;

writeln ('Сумма элементов массива: ',s);

writeln ('Среднее арифметическое элементов массива: ',s/6:0:1)

end.

Объяснение:

Цикл:

1) присваиваем значение текущему элементу массива

2) выводим текущий элемент массива на экран

3) считаем сумму элементов массива

Выводим сумму элементов массива на экран

Выводим среднее арифметическое элементов массива на экран (делим сумму на количество элементов), используя форматированный вывод (указываем после второго двоеточия количество знаков после запятой при выводе числа)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика