На языке с или с++ написать программу . натуральное число называется числом армстронга, если сумма цифр числа, возве-денных в n-ную степень (где n – количество цифр в числе) равна самому числу. например, 153 = 13 + 53 + 33. найдите все трёхзначные армстронга.

ObraztsovaOlga ObraztsovaOlga    2   31.07.2019 10:20    8

Ответы
filip198585 filip198585  03.10.2020 18:28
#include <iostream>
using namespace std;

int main()
{
    int n,s;
    for (int i=100; i<=999; i++)
     {
      n = i % 10;
      s = n*n*n;
      n = i / 10 % 10;
      s = s+n*n*n;
      n = i /100;
      s = s+n*n*n;
      if (i == s) cout << i << "\n";
     }
    return 0;
}

Результат:
153
 370
 371
 407
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика