На языке паскаль абс написать программу (не глушилку , а нормальную программу)(желательно с циклов и if-ов) натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая само число. например, совершенным является число 6 (6=1+2+3). необходимо найти все совершенные числа, меньшие заданного числа n. формат входных данных вводится одно целое число n (1≤n≤100000). формат выходных данных требуется вывести все совершенные числа, меньшие заданного числа n. числа следует выводить в порядке возрастания, разделяя пробелами. примеры входные данные выходные данные 7 6

HiDolr HiDolr    2   08.06.2019 16:30    3

Ответы
galaxykill galaxykill  07.07.2020 19:12
Ну Хьюстон почти все уже сделал. Я чуток подправил
var i,j,s,n:integer; 
begin
readln(n);
for i := 1 to n-1 do
  begin
  s:=0;
  for j := 1 to (i div 2) do
     if i mod j=0 then s:=s+j;
  if s=i then write(i,' ');
  end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика