На языке pascalabc.net: 2) разработать программу циклической структурой в соответствии с предложенным вариантом, используя цикл с предусловием. дано действительное число х, натуральное число n. написать программу, которая вычисляет сумму последовательности, заданной формулы x^1/1! +x^2/2! +x^3/3! ++x^n/n!

Маргоритка11 Маргоритка11    2   31.07.2019 12:10    2

Ответы
оьмдды оьмдды  03.10.2020 18:34
//PascalABC.NET 3.1 сборка 1239
begin
    var x := ReadReal('x =');
    var s := 0.0;
    var a := 1.0;
    
    for var i := 1 to ReadInteger('n =') do
    begin
        a *= x / i;
        s += a;
    end;
    writeln(s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика