На вход программы поступает последовательность из n неотрицательных целых чисел, каждое из которых не больше 1000. требуется определить, какая сумма цифр чаще всего встречается среди этих чисел. если таких значений несколько, необходимо вывести наибольшее из них. входные данные: на вход программе подаётся натуральное число n (n< = 1000), а затем n натуральных чисел, каждое из которых не превышает 1000. пример входных данных: 3 13 22 32 выходные данные: программа должна вывести наибольшую сумму цифр, которая чаще всего встречается среди введённых чисел. пример выходных данных для примера входных данных: 4 два числа имеют сумму цифр 4. паскаль abc

AgafAl AgafAl    1   02.09.2019 10:30    29

Ответы
Potterhead01 Potterhead01  06.10.2020 11:52
Егэ:)

var N, x, sum, maxi, i:integer;
a:array [0..27] of integer;
begin
readln(N);
sum:=0;
for i:=1 to N do beginreadln(x);
while x>0 do beginsum:=sum+x mod 10;x:=x div 10;end;a[sum]:=a[sum]+1;sum:=0;end;
for i:=0 to 27 doif a[i]>maxi then maxi:=i;
writeln(maxi);end.
На вход программы поступает последовательность из n неотрицательных целых чисел, каждое из которых н
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика