На вход программы поступает последовательность из n натуральных чисел. нужно выбрать из них произвольное количество чисел так, чтобы их сумма была максимальной и не делилась на 4. в результате программа должна вывести количество выбранных чисел и их сумму. если получить требуемую сумму невозможно, в качестве ответа нужно выдать 0. входные данные: на вход программе подаётся натуральное число n (n  1000), а затем n натуральных чисел, каждое из которых не превышает 10000. пример входных данных: 3 1 2 1 выходные данные: программа должна вывести два числа: сначала количество выбранных чисел, а затем их сумму. пример выходных данных для примера входных данных: 2 3 паскаль

Grazhdankin Grazhdankin    1   31.08.2019 23:40    13

Ответы
lisena123409 lisena123409  06.10.2020 08:38
Var
  a, n, i, sum, c, min: integer;
 
begin
  sum := 0;
  c := 0;
  min := 10001;
  read(n);
  for i := 1 to n do begin
    read(a);
    sum := sum + a;
    c := c + 1;
    if(a < min) and (a mod 4 <> 0) then min := a;
  end;
  if(sum mod 4 = 0) and (min <> 10001) then begin sum := sum - min; c := c - 1; end;
  if(sum mod 4 = 0) then begin write(0); exit; end;
  writeln(c, ' ', sum);
 end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика