На вход программе подаются два целых числа a и b (a≤b). Напишите программу, которая подсчитывает количество чисел в диапазоне от a до b включительно, куб которых оканчивается на 4 или 9. Формат входных данных

На вход программе подаются два целых числа a и b (a≤b).

Формат выходных данных

Программа должна вывести одно целое число в соответствии с условием программы.

Примечание. Куб числа aa – это его третья степень a^3a

.

кузя216 кузя216    1   22.01.2021 07:28    125

Ответы
ziminasofa2703 ziminasofa2703  22.01.2021 07:30

pascal

Объяснение:

var

 a, b, col: integer;

begin

 repeat

   Write('Введите число a: '); ReadLn(a);

   Write('Введите число b: '); ReadLn(b);

 until a<=b;

 repeat

   if ((sqr(a)*a) mod 10 = 4) or ((sqr(a)*a) mod 10 = 9) then inc(col);

   inc(a);

 until a>b;

 WriteLn('Количество чисел в диапазоне от ', a, ' до ', b,

         ' включительно, куб которых оканчивается на 4 или 9 равно ', col);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика