На вход программе подается натуральное число n < = 109. проверьте, является ли оно простым. выведите yes или no в зависимости от ответа на вопрос . максимальное время работы программы на одном тесте — 0,1 секунды.

Sashka15081 Sashka15081    3   10.07.2019 10:40    8

Ответы
BlackBear2517 BlackBear2517  17.09.2020 12:06
Var
a,flag,i:integer;
Begin
Readln(a);
flag:=0;
for i:=2 to a do begin 
if i<>a then if a mod i=0 then 
begin flag:=1; break; end;  end;
if flag=1 then Writeln('NO')
else Writeln('YES')
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика