На вход программе два целых числа: 0 < n < = 12, 0 < = m < 60, указывающие момент времени “n часов m минут”. определите наименьшее число полных минут, которое должно пройти до того момента, когда часовая и минутная стрелки на циферблате совпадут, не обязательно на каком-то делении. вещественную арифметику не использовать. abc pascal. пришлите скрин или полную запись программы

AnonimkaNya AnonimkaNya    3   06.07.2019 14:10    9

Ответы
andreydikenson1 andreydikenson1  02.10.2020 21:18
Var h,m,c:integer;
begin
write('введите часы => ');
readln(h);
write('введите минуты => ');
readln(m);
if (h=12) then h:=0;
if (m < h*5) then c:=h*5-m; 
if (m > h*5) then c:=(60-m)+5;
writeln('стрелки совпадут через ',c,' минут');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика