На vba: дано число. составить программу, которая определяет. входит ли в него цифра 3.

nikniksergeev1 nikniksergeev1    3   21.05.2019 13:20    4

Ответы
annachernoirova annachernoirova  15.06.2020 21:50

Дам 2 кода на с++ и на паскаль, попробуешь перевести на VBA . не сложно.

с++

int a,b,count(0);;
cin>>a;
while(a>0)
{
b=a%10;
if (b==3) count++;
a/=10;
}
if (count > 0) cout<<"OK";
else cout<<"NO";

 

pascal как то так

uses crt;

var a,b,count:integer;
begin
readln(a);
count:=0;

while a > 0 do
begin
b:=a mod 10;
if b = 3then inc(count);
a:=a div 10;
end;
if count > 0 then writeln('ok')
else
writeln('NO');
readln;
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика