На с++ составить программу, которая запрашивает у пользователя два целых числа и выводит сумму квадратов а^2+b^2 этих чисел. пример работы программы a=3 b=2 сумма квадратов равна 13.

Ласточка005 Ласточка005    2   24.04.2019 18:39    2

Ответы
cacalohgf cacalohgf  08.06.2020 19:33

#include <iostream>

#include <cmath>  // подключаем файлы с библиотекой для возведения в степень

using namespace std;

 

int main() {

   long long a, b;  // инициализируем 2 переменных типа long long

   cin >> a >> b;  // вводим числа

   cout << 1LL * (pow(a, 2) + pow(b, 2))  << endl;  // выводим результат

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика