На с++ напишите программу, которая вычисляет сумму элементов матрицы. входные данные в первой строке записаны через пробел размеры матрицы: количество строк n и количество столбцов m ( 1 ≤ n , m ≤ 100 ). в следующих n строках записаны строки матрицы, в каждой – по m натуральных чисел, разделённых пробелами. выходные данные программа должна вывести одно число – сумму элементов матрицы. примеры входные данные 4 5 1 2 3 4 5 6 12 8 9 10 11 12 12 14 15 16 17 18 12 20 выходные данные 207

katirina61171Rfn katirina61171Rfn    2   21.09.2019 06:10    4

Ответы
jasmine9 jasmine9  10.09.2020 13:20
//g++  5.4.0

#include <iostream>
#include <vector>
using namespace std;
int main()
{
    size_t N, M, sum{ 0 };
    cin >> N >> M;
    vector<vector<int>> v(N, vector<int>(M));
    for (size_t i = 0; i < N; ++i) {
        for (size_t j = 0; j < M; ++j) {
            cin >> v[i][j];
            sum += v[i][j];
            cout << v[i][j] << " ";
        }
        cout << endl;
    }
    cout << sum << endl;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика