на С++ написать программу, которая выводит заданное число на экран, а также сумму и произведение его цифр.

УмничкаХороша УмничкаХороша    1   08.02.2021 10:10    3

Ответы
katia6747 katia6747  10.03.2021 10:10

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_ALL, "russian");

int n, a=0, b=1;

cin >> n;

while (n > 0)

{

a += n % 10;

b *= n % 10;

n = n / 10;

}

cout << "Сумма цифр равна:" << a << "\nПроизведение цифр равно:" << b;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика