На С++ написать программу Дано натуральное число. Определить, сколько раз в нём встречается первая цифра.

сайнорбой сайнорбой    1   11.06.2021 22:40    12

Ответы
anavasko21 anavasko21  11.07.2021 22:41

#include <iostream>

using namespace std;

 

int main()

{

   int N, N1, count=0;

   

   cout << "N="; cin >> N;

   

   N1=N;

   

   while (N>=10)  

   {  

       N/=10;

   }

   

   while (N1)  

   {

       if(N1%10==N) count++;

       N1/=10;

   }

   

   cout << "count=" << count << "\n";

   

system("pause");

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика