На PYTHON; Составьте программу для возведения любого числа в любую натуральную степень используя цикл FOR​

kirill600rr12 kirill600rr12    1   20.10.2020 00:18    6

Ответы
мим221 мим221  19.11.2020 00:19

p = int(input("Показатель степени: "))

n = int(input("Предел: "))

i = 1

while i ** p <= n:

   print(i ** p, end=' ')

   i += 1

print("\nПоследнее число,"

     " возведенное в степень:", i - 1)

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
1g00se1 1g00se1  19.11.2020 00:19

a = int(input("Введите число "))

c = int(input("Введите степень "))

s = 1

for i in range(c):

   s = s * a

print(s)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика