На Python
Самое частое число
Дан список. Не изменяя его и не используя дополнительные списки, определите, какое число в этом списке встречается чаще всего.

Если таких чисел несколько, выведите любое из них.

Входные данные

Вводится список чисел. Все числа списка целые, по модулю не превосходят 1000 и находятся на одной строке.

Выходные данные

Выведите ответ на задачу.

Примеры
Ввод
Вывод
1 1 1 1 2 2 2 3 3 3
1

kaka932 kaka932    1   20.05.2020 22:29    412

Ответы
visaenko1974 visaenko1974  15.10.2020 03:20

lst = [int(_) for _ in input().split()]

dictionary = dict()

for num in lst:

   if num in dictionary:

       dictionary[num] += 1

   else:

       dictionary[num] = 1

print(max(dictionary.items(), key=lambda x: x[1])[0])

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика