На питоне без использования if и while Ваня наблюдает за лягушкой

Ваня наблюдает за лягушкой. Изначально она сидит в точке 0 числовой прямой. Каждую секунду она прыгает на 1 вправо, пока не достигнет точки K. Затем она начинает каждую секунду прыгать на 1 влево, пока не вернется в точку 0, затем – опять вправо и т. д. Требуется определить, где окажется лягушка через T секунд.

Входные данные

Вводятся два числа K и T, разделенные пробелом. Оба числа натуральные и не превосходят 1 000 000 000.

Выходные данные

Вывести одно число – координату лягушки в момент времени T.

TamiDobro TamiDobro    3   15.08.2021 00:38    26

Ответы
vovadavydov56 vovadavydov56  15.08.2021 01:00

k, t = [int(i) for i in input().split()]

a = t % k

b = t // k

m = k - a

c = t

for i in range(b):

   c = m

   g = m

   m = a

   a = g

print(c)

Объяснение:

попробуй это

ПОКАЗАТЬ ОТВЕТЫ
aliseymur7 aliseymur7  14.09.2021 01:49

Pascal:

var

k,t,x: integer;

begin

readln(k, t);

x := abs(t mod k - k*sqr(t div k and 1));

writeln(x);

end.

Python:

k, t = input().split()

print(abs(int(t) % int(k) - int(k) * (int(t) //  int(k) and 1) ** 2))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика