На паскале составить программу нахождения наибольшего общего делителя трех чисел , испол. след. формулу: нод(а,в,с)=нод(нод(а,в),с)

Настя9474 Настя9474    3   21.05.2019 04:50    6

Ответы
иляяя1яяя иляяя1яяя  15.06.2020 02:50

function NOD (x,y:longint):longint;
begin
if x=0 then NOD:=y
else
if y=0 then NOD:=x
else
if x>y then NOD:=NOD(x mod y,y)
else
NOD:=NOD(x,y mod x);
end;

var
a,b,c:longint;
begin
read(a,b,c);
writeln('NOD (',a,',',b,',',c,') = ',NOD(NOD(a,b),c));
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика