На паскале продолжительность фильма 3416 секунд напишите программу которая вычислит сколько это полных минут

DiModDi DiModDi    3   22.10.2019 22:13    3

Ответы
Kaaaaakkkktus Kaaaaakkkktus  10.10.2020 08:54

VAR seconds, minutes :Integer;

BEGIN

seconds := 3416;

minutes := seconds DIV 60;

WriteLn(minutes);

ReadLn

END.

Объяснение:

Первая строка задаёт целочисленные переменные.

BEGIN и END - начало и конец программы соответственно.

3 строка - присвоение переменной seconds значения 3416.

4 строка - целочисленное деление, т. е. деление на 60 без остатка.

WriteLn печатает результат 56, т. е. 56 полных минут.

ReadLn не даёт программе закрыться, пока пользователь этого не захочет.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика