На паскале написать программу сокращения дроби , где n – целое, m – натуральное число. использовать алгоритм евклида. разработать тесты для проверки правильности работы программы.

kirill885 kirill885    1   19.07.2019 09:20    8

Ответы
rim2891 rim2891  22.09.2020 12:08
Program ex2;
uses crt;
var a, b, x: real;
begin clrsc;
write('a='); readln(a);
write('b='); readln(b);
{алг. Евклина для НОД}
end.
ПОКАЗАТЬ ОТВЕТЫ
руслан7661 руслан7661  22.09.2020 12:08
Var
 n,m:integer;
 a,b:integer;
begin
 read(n,m);
 a := abs(n);
 b := m;
 while a <> b do
   if a > b then
     a := a - b
   else
     b := b - a;
 b := m div a;
 a := n div a;
 writeln(a,'/',b);
 if a*m = b*n then writeln('Correct')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика