На паскале.
4. Девятиклассники участвовали в викторине по математике. Необходимо было ответить на 20
во Победителем викторины считается участник, правильно ответивший на наибольшее
количество во На сколько во победитель ответил правильно? Если есть
участники викторины, которые не смогли дать правильный ответ ни на один из во выведите YES, иначе выведите NO. Гарантируется, что есть участники, правильно ответившие
хотя бы на один из во Программа получает на вход число участников викторины N (1 ≤ N ≤ 50), затем для каждого
участника вводится количество во на которые получен правильный ответ

Аринаqwe Аринаqwe    2   23.04.2020 21:05    6

Ответы
mushicz mushicz  13.10.2020 19:22

var N, i, a, m:integer;

c:boolean;

begin

 writeln('Введите количество участников');

 readln(N);

 if ((N < 1) or (N >50))then begin

   writeln('Ошибка');

   exit;

 end;

 m := 0;

 c := false;

 for i:=1 to N do begin

   writeln('На сколько вопросов правильно ответил ',i,' участник:');

   readln(a);

   if ((a < 0) or (a > 20)) then begin

     writeln('Ошибка');

     exit;

   end;

   

   if (a = 0) then

     c := true;

   

   if (a > m) then

     m:= a;

 end;

 writeln('Количество вопросов, на которые ответил победитель правильно: ', m);

 if (c = false) then

   writeln('Есть ли участники, которые не ответили ни на один вопрос правильно: NO')

 else write('Есть ли участники, которые не ответили ни на один вопрос правильно: YES');

 

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика