Н.1. Составить программу, которая в последовательности целых чисел определяет кол-во элементов, подходящих  под условие: Число двузначное, нечетное, оканчивается на 3.
Сначала, пользователь вводит Кол-во чисел, затем сами числа.

ВеликийМаг2018 ВеликийМаг2018    2   22.01.2022 10:25    1

Ответы
MaliaCr MaliaCr  22.01.2022 10:30

Pascal:

var

 n, i, a, c: Integer;

begin

 Read(n);

 c := 0;

 for i := 1 to n do begin

   Read(a);

   if (a div 100 = 0) and (a mod 10 = 3) then

     c := c + 1;

 end;

 WriteLn(c);

end.

Python:

n = int(input())

c = 0

for i in range(0, n):

   a = int(input())

   if (a // 100 == 0) and (a % 10 == 3):

       c += 1

print(str(c))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика