Можно программу на языке паскаль ":) Составить программу нахождения суммы всех делителей заданного натурального числа N.
(Само число и единица включаются в число делителей.)

Формат входных данных
Входной файл содержит число N (1≤N≤1000).

Формат выходных данных
Выведите искомую сумму.

Примеры:
Вход
3
Выход
4

nastysh20011 nastysh20011    2   13.12.2020 13:33    13

Ответы
AishaZamyjem8 AishaZamyjem8  12.01.2021 13:36

var sum,i,N:integer; t,t1:text;

begin

 assign (t, 'input.txt'); reset(t);

 assign (t1, 'output.txt'); rewrite(t1);

read(t,N);

sum:=0;

for i:=1 to N do

 if N mod i = 0 then sum:= sum+i;

write(t1,sum);

close(t1)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика