Много программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 6 и оканчивающихся на 4. программа получает на вход количество чисел в последовательности, а затем сами числа. количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: количество чисел, кратных 6 и оканчивающихся на 4. input 3,24,25,54 result2

mazaliaopera mazaliaopera    3   25.09.2019 10:30    2

Ответы
Alieta Alieta  08.10.2020 18:10
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  ReadSeqInteger(ReadlnInteger)
      .Where(t->(t mod 6=0) and (t mod 10=4)).Count.Println
end.
ПОКАЗАТЬ ОТВЕТЫ
onion2 onion2  08.10.2020 18:10
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

int main()
{
    size_t size, value, count; 
    cin >> size;
    vector<int> v;
    for (size_t i = 0; i < size; ++i) { 
        cin >> value; 
        v.push_back(value); 
    }
    count = count_if(v.cbegin(), v.cend(), [](const int& i) { return (i % 6 == 0) | (i
% 10 == 4); });
    cout << count;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика