Много !
как в паскале написать программу:
вывести первые n степеней числа 2, начиная с нулевой. найти сумму цифр введенного числа.

Ksu576 Ksu576    1   07.11.2019 19:07    2

Ответы
Остап1843 Остап1843  10.10.2020 11:46

var a,b,c,d:integer;

begin

writeln('введите число'); //запрос числа

readln(a);

d:=a;                 //это для красоты

while (a<>0) do begin //пока мы не дойдём до последней цифры в числе делать следующее

 b:=a mod 10;        //берём последнюю цифру числа  

 c:=c+b;             //находим сумму цифр

 a:=a div 10;        //убираем из данного числа последнюю цифру

 end;

 writeln('сумма цифр числа ',d,' = ',c); // вывод результата

end.

Вроде вот)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика