Много 1. написать программу, которая заполняет массив с клавиатуры целыми числами и распечатывает его элементы в обратном порядке. массив описывается через константу n. для проверки взять n=5. то есть выводится a[5], a[4],…,a[1]. пример выполнения программы: входные данные выходные данные 2 3 6 4 8 --> 8 4 6 3 2 2. написать программу, которая выводит на печать каждый третий элемент массива (или те элементы, индекс которых кратен 3). массив описывается через константу n. для проверки взять n=10. пример выполнения программы: входные данные выходные данные 1 2 3 4 5 6 7 8 9 10--> 3 6 9

11UmNiK111 11UmNiK111    3   19.07.2019 06:00    11

Ответы
NIKCHplay NIKCHplay  03.10.2020 07:38
1.
const n=5;
var
a: array[1..n] of integer;
i: integer;
begin
for i:=1 to n do
read(a[i]);
for i:=n downto 1 do
write(a[i], ' ');
end.

2.
const n=10;
var
a: array[1..n] of integer;
i: integer;
begin
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if i mod 3 = 0 then
write(a[i], ' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика