Методика выполнения работы 1. программа имеет линейную структуру в соответствии с алгоритмом на рис. 5.2. s1 – блок ввода исходных данёных a, b, c. s2 – блоки расчета полупериметра треугольника p и площади s. s3 – блок вывода результата: площадь s. введите программу решения этой (см. пп. 1-3, лабораторная работа № 1). program geron; uses crt; var a,b,c,p,s: real; begin clrscr; {ввод исходных данных} writeln(‘введите значения сторон треугольника a,b,c’); readln(a,b,c); {расчет полупериметра и площади треугольника} p: = 0.5*(a+b+c); s: =sqrt(p*(p-a)*(p-b)*(p-c)); {вывод результата расчета} writeln(‘площадь треугольника = ’, s: 5: 3) end. 2. откомпилируйте программу и исправьте возможные ошибки. затем запустите программу на счет (см. пп. 4-5, лабораторная работа № 1). 3. проведите тестовый расчет, чтобы убедиться в правильности работы программы. введите значения сторон: a=1, b=1, c=1. должен получиться результат s=0.433. 4. проведите серию расчетов для различных значений сторон треугольника. 5. если значения сторон являются константами (например, все равны 1), то в данную программу можно ввести следующие изменения:  перед разделом var надо добавить раздел констант – const a=1; b=1; c=1;  из раздела var убрать a,b,c – var p,s: real;  убрать ввод исходных данных – удалить операторы writeln(‘введите…’); readln(a,b,c); 6. сделайте указанные исправления и повторите пп. 1-3 данной работы. для самостоятельной работы составить программу на языке паскаль для нахождения значения выражения. константы a, b, c вводятся с клавиатуры. сложные аргументы функций вычислять отдельно, tan(x) вычислять как sin(x)/cos(x), ctan(x) → cos(x)/sin(x), xy → exp(y*ln(

ПолинаТришинкова ПолинаТришинкова    3   23.04.2019 14:59    2

Другие вопросы по теме Информатика