"массив в состоит из 15 элементов заполненными от 0 до 50 радномно, вычислите количество четных элементов" напишите программу паскаля

nastyankazau112 nastyankazau112    2   14.08.2019 17:40    3

Ответы
VanilRio VanilRio  04.10.2020 19:17
Var a: array [1..15] of integer; 
  i,n:integer;
begin
for i:=1 to 15 do begin 
    a[i]:=random(50); 
    if (a[i] mod 2)=0 then    
        n:=n+1;
end;
writeln(a);
writeln;
writeln(n);
end.
ПОКАЗАТЬ ОТВЕТЫ
genalysenko98 genalysenko98  04.10.2020 19:17
Uses crt;
Var a:array [1..15] of integer;
i,k:integer;
begin
for i:=1 to 15 do
begin
a[i]:=random(50)-20;
write (a[i]:4);
k:=0;
end;
writeln;
for i:=1 to 15 do
if a[i]>0 then
begin
k:=k+1;
end;
writeln ('колво элементов',k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика