tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Массив одномерный a
Массив одномерный a n элементов подсчитать произведение отрицательных элементов этого массива решите , вопрос жизни и смерти
Даниил20061605
3 08.07.2019 06:50
7
Ответы
MarGGoTV
02.10.2020 22:42
Turbo Pascal
USES CRT;
VAR A:array[1..100] of integer;
i,n,summa:integer;
BEGIN
CLRSCR;
Randomize;
{Проверяем на размер массива, чтобы не превышал 100}
Repeat
Writeln('Введите размер массива до 100');
Readln(n);
Until n<=100;
{Заполняем массив случайными числами от -50 до 100}
For i:=1 to n do
begin
A[i]:=-50+Random(100);
Write(A[i],' ');
end;
summa:=0;
{Находим отрицательные элементы массива и складываем}
For i:=1 to n do
if A[i]<0 then summa:=summa+A[i];
Writeln;
Writeln('Сумма отрицательных элементов массива = ',summa);
READLN;
END.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
D1manch1k
20.05.2021 08:00
Если сможете решть эту задачу за это. Ты сможешь Бабушка эмира любит готовить баурсаки. В первый день он готовил 5 баурсаков, в последующие дни он готовил в 2 раза больше,...
leradolgolenko
20.05.2021 08:00
Python. Напишите программу, которая в заданном предложении заменяет все строчные буквы прописными (в том числе русские буквы)....
aeivanovakr2000
20.05.2021 07:58
ТЕКСТ ЗАДАНИЯ Определите стиль текста 02.Текст 2.Тема альтернативных источников энергиистановится все актуальнее и переходит изплоскости разговоров и дискуссий в активныедействия....
N1R2
20.05.2021 07:57
Бабушка эмира любит готовить баурсаки. В первый день он готовил 5 баурсаков, в последующие дни он готовил в 2 раза больше, чем в предыдущий. Подсчитайте, сколько баурсаков...
Янина7005
20.05.2021 07:57
Придумай и напиши небольшой рассказ (6-10 предложений) для новой компьютерной игры для детей 5-6 лет!...
eroly12ramblerr2
22.07.2019 00:30
Вы хотите работать с разрешением монитора 1600×1200 пикселей,используя 16777216 цветов.в магазине видеокарты с паметью 512 кбайт,2мбайт,4 мбайт и 64мбайт.какую из них можно...
YeezyM
22.07.2019 00:30
Какой объем видеопамяти необходим для хранения четырех страниц изображения ,если битовая глубина равна 10,а разрещающая дисплея - 800 на 600 пикселей ?...
ромашка261
15.08.2019 16:10
Вматрице h(6×5) определите в каждой строке произведение положительных элементов...
koliskynakate20
15.08.2019 16:10
Величина, которая может изменять свое название в ходе выполнения программы...
Элайза2004
06.07.2019 05:30
Перевести числа из двоичной системы счисления в десятичную: 111011101, 1011111000, 111110100, 110001111, 1011101110, 1111101011, 110100110....
Популярные вопросы
Переведи в указанные единицы измерения? 1дм.1см.=? см. 12см.=? ....
3
Биссектрисы углов в и с треугольника авс пересекаются в точке к.найдите...
2
Запишите частное. в виде смешаного числа7/3; 22/6; 100/16; 275/100$$(...
3
Космонавт пробыл на орбите 54дня.в конце каждой декады он посылал сообщение...
3
При нагрузке в 200н пружина динамометра удлинилась на 0,5см. на сколько...
2
При изотермическом сжатии одноатомного газа давление газа увеличилось...
3
Решить ! ,,сумма вертикальных углов, образованные при пересечении двух...
3
Альбом который стоил 120р . продается с 25%- ой скидкой. при покупке...
1
Вкаком слове у ь знака не такая работа как у других слов 1) молодежь...
2
Составить 5 предложений в past simple утвердительных предложений и 5...
1
USES CRT;
VAR A:array[1..100] of integer;
i,n,summa:integer;
BEGIN
CLRSCR;
Randomize;
{Проверяем на размер массива, чтобы не превышал 100}
Repeat
Writeln('Введите размер массива до 100');
Readln(n);
Until n<=100;
{Заполняем массив случайными числами от -50 до 100}
For i:=1 to n do
begin
A[i]:=-50+Random(100);
Write(A[i],' ');
end;
summa:=0;
{Находим отрицательные элементы массива и складываем}
For i:=1 to n do
if A[i]<0 then summa:=summa+A[i];
Writeln;
Writeln('Сумма отрицательных элементов массива = ',summa);
READLN;
END.