Массив из 10 элементов заполняется целыми числами. составьте программу, которая вычисляет среднее арифметическое элементов, заканчивающихся на цифру 7

Макс228336 Макс228336    3   25.08.2019 04:40    3

Ответы
55555Даша11111111111 55555Даша11111111111  05.10.2020 18:04
Const
K = 10;
Var
A:array[1..K] of integer;
S,i,n:integer;
Begin
S:=0;
n:=0;
Write('Исходный массив: ');
For i:= 1 to K do
    Begin
    A[i]:=random(201)-100;
    Write(A[i],' ');
    if A[i] mod 10 = 7 then
       Begin
       S:=S+A[i];
       n:=n+1
       End;
    End;
WriteLn;
if n = 0 then WriteLn('В массиве нет элементов, оканчивающихся на семь')
else WriteLn('Среднее арифметическое элементов, оканчивающихся на семь: ',S/n);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика