tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Масса каждого из 25 человек
Масса каждого из 25 человек хранится в массиве людей, имеющих массу более 100 кг будем условно называть полными (известно,что есть по меньшей мере один такой человек). определите среднюю массу полных людей, и среднюю массу остальных людей
bezrodnayamila
2 17.09.2019 11:00
12
Ответы
kisasay1123
07.10.2020 21:40
//PascalABC.NET
//Версия 3.3, сборка 1627 (27.01.2018)
begin
var l:=ArrRandom(25,50,150); l.Println;
Writeln('Среднее полных-> ',l.Where(t->t>=100).Average:0:4);
Writeln('Среднее остальных-> ',l.Where(t->t<100).Average:0:4);
end.
Пример:
55 108 131 58 141 62 102 56 118 78 128 114 110 66 134 74 71 56 103 126 76 133 118 99 101
Среднее полных-> 119.0714
Среднее остальных-> 68.2727
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
dasha1832
21.12.2020 16:33
Определи с которого был изменён размер круга...
dedpul23
21.12.2020 16:33
Градиент, используемый для заливки фигур...
Galya03
21.12.2020 16:32
Решить задачу с кругов Эйлера. 20 человек знают английский и 10немецкий, из них 5 знают и английский, инемецкий. Сколько человек всего?...
olegmuslimov778
02.05.2020 13:37
Составить программу, которая выводит число последовательности с номером N (вводится). Первые два числа 0 и 1, а каждое последующее равно сумме двух предыдущих (числа 0, 1,...
hhjjkh
02.05.2020 13:37
Програма для виконавця в середовищі Скретч КТО ЗНАЕТ ЭТО ОЧЕНЬ...
sdtyvbv
02.05.2020 13:38
2. Отметьте все правильные утверждения о беспроводных мышах. им нужны батарейки или аккумуляторы для обмена данными они используют радиоволны они должны быть соединены кабелем...
yulia3789
02.05.2020 13:38
Назви приклади об єктів які можна використати у проектах у середовищі скреч...
sofika121
18.10.2020 22:54
Найдите объём сообщений : Предложение- текстовый редактор- программа для обработки текстовой информации. ...
vanuytoa
18.10.2020 22:54
Представьте информацию о погоде в различной форме...
linochka1083
18.10.2020 22:35
ответить на вопросы всё . ...
Популярные вопросы
1)Как раскрыть скобки , если перед скобками стоит знак(+)? ... 2) Как раскрыть...
1
Как вы понимаете смысл цитаты Если сделал что-то хорошее от этого радость...
1
Сформулюйте умову задачі і виріште ії. Т1=?; V-const; P2=P1+0,02p1; T2=T1+6....
1
1.Выберите результат выполнения этой команды writeln(x) 2.Выберите результат...
3
1. Раскрой скобки (Не)к лицу; (не)ровность на дороге; (не)асфальтированная...
3
Неопределенный интеграл Задание...
2
Укажите допустимые значения переменной в выражении:(уравнение выше)...
3
Привет с Английским участники) of The London Marathon run? 4.How many people...
3
К осадочным горным породам относится а) мрамор б) гнейс в)известняк г) базальт...
3
Природа на берегах водоёмов.Очень красивы берега рек, озёр, во-дохранилищ...
3
//Версия 3.3, сборка 1627 (27.01.2018)
begin
var l:=ArrRandom(25,50,150); l.Println;
Writeln('Среднее полных-> ',l.Where(t->t>=100).Average:0:4);
Writeln('Среднее остальных-> ',l.Where(t->t<100).Average:0:4);
end.
Пример:
55 108 131 58 141 62 102 56 118 78 128 114 110 66 134 74 71 56 103 126 76 133 118 99 101
Среднее полных-> 119.0714
Среднее остальных-> 68.2727