Люди, написать программу в паскале. нужно,чтобы сравнивалась дробная и целая часть вещественного числа,если она одна и та же,то тру,если нет,то false. допустим 12.12 будет тру,а если нет,то фолс. проблема в том,что через fruc и int сравнивается 12 и 0.12. домножать на 100 нельзя,тк это универсальная программа,может быть и число 123.123

Orange717 Orange717    3   19.09.2019 07:20    3

Ответы
visnevsk visnevsk  08.10.2020 01:43
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadReal('Введите число:').ToString.ToWords('.');
  if a.Length=2 then Writeln(a[0]=a[1])
  else Writeln(False);
end.

Примеры
Введите число: 121.121
True

Введите число: 12.11999
False
ПОКАЗАТЬ ОТВЕТЫ
2006215 2006215  08.10.2020 01:43
Var
  V: real;
  c,b: integer;
begin
  writeln('Введите число');
  readln(V);
  c:=round(V);
  V:=V-c;
  b:=c;
  while c>0 do begin
     c:=c div 10;
     V:=V*10;
  end;
  c:=round(V);
  V:=V-c;
  if round(V*10000)<>0 then
     writeln('части не равны')
  else begin
    if b=c then
      writeln('части равны') 
    else
       writeln('части не равны');
  end;
    
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика