ЛЮДИ ДОБРЫЕ УМОЛЯЮ Напишите программу в Паскале, которая выводит случайное число в промежутке от 15 до N. Значение N вводится с клавиатуры и N ( знак больше)15.

KolianN KolianN    3   05.05.2020 21:42    5

Ответы
ImHomme ImHomme  24.08.2020 13:23

Должно работать это:

var N,r:integer; //нужные нам переменные

begin //СТАРТУЕМ!

 writeln('Впишите N. . .');  //просим ввести N

 readln(N); //получаем N

 randomize; //без этого рандом выдаёт одно и то же

 r := random(N-15+1)+15; //формула раандома

 writeln(r); //выводим рандомное число

end. //выключаем программу

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика