Лёгкая по паскалю! , ! составьте программу которая позволяет удалить второе слово строки s. строку s, состоящую из 2 слов, разделённых пробеламі, введите с клавbатуры.

moni9 moni9    3   14.08.2019 05:50    3

Ответы
Лисичка6661 Лисичка6661  04.10.2020 17:57
Var s: string; x,i: byte;
begin
writeln('Введите строку:');
readln(s);
for i:=2 to length(s) do begin
  if s[i]=' '
    then begin
      x:=i+1;
      while (s[x]<>' ') and (x<length(s)) do begin
        delete(s,x,1);
      end;
      delete(s,x,1);
      break;
    end;
end;
writeln(s);
end.

Пример 1:
мама мыла
мама 
Пример 2:
Мама мыла раму
Мама раму

PS: считается, что строка не начинается с пробела и не может быть два пробела подряд
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика