tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Лёгкая по паскалю! , !
Лёгкая по паскалю! , ! написать программу которая удаляет все точки і запятые из строки s.
анжела286
3 14.08.2019 05:50
6
Ответы
aleksandrovauli
04.10.2020 17:59
Решение для одного-двух разных удаляемых символов
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
s:=s.Replace('.','').Replace(',','');
s.Println
end.
Пример
> Раз, два, три, четыре, пять. Вышел зайчик погулять.
Раз два три четыре пять Вышел зайчик погулять
Решение, когда разных удаляемых символов может быть много
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
s:=s.Where(с->not(с in [',','.'])).JoinIntoString;
s.Println
end.
ПОКАЗАТЬ ОТВЕТЫ
сичоврчс
04.10.2020 17:59
Pasca
program eazy;
var s:string;
i:integer;
begin
writeln('Vvedite tekst');
readln(s);
for i:=length(s) downto 1 do
if (s[i]=' ') or(s[i]=',') or (s[i]='.') then
delete(s,i,1) ;
writeln(s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Lasaolnaser
23.08.2019 02:50
Слоговое индийское письмо деванагари использует комбинации 89 различных символов. какое минимальное количество битов требуется для записи одного символа?...
Ha4uk
23.08.2019 02:50
Написать текст для поздравления женщин с 8 марта ( надо)...
agharkova2014
23.08.2019 02:50
Найти сумму всех четных натуральных чисел от 2-х до n...
taras9877
19.06.2019 17:20
Системный блок это устройство ввода или вывода?...
beelan3
19.06.2019 17:20
1)носитель информации имеет объем 1 гбайт. сколько мбайт памяти останется свободно , если разместить на нем 16 книг, состоящих из 256 страниц. на каждой странице 80 строк по 64 символов....
Gfykfyj
19.06.2019 17:20
Даны три числа . найти среднее арифметическое и среднее этих чисел. паскаль,для программы algo...
Divas888
22.10.2019 19:24
Соч по информатике, сколько угодно...
rodion905
22.10.2019 19:21
Написать на pascal abcвсем известно, что многие олимпиадные начинаются со слов «всем известно». но мало кто знает, что начинающему программисту паше такие меньше всего нравятся. потому...
Alisarive
15.04.2020 14:16
Как вычислить значение истинности X&(Y→¬X&¬Y)v¬Z, если X=0 Y=0 Z=1. С решением...
vecronika54
15.04.2020 14:16
9 класс. Приведите по 2 примера ситуаций из любой профессиональной деятельности, где может быть использована КОМПЬЮТЕРНАЯ...1) физическая модель. 2)биологическая модель. 3)вероятностная...
Популярные вопросы
Решите ! 12 1.верно ли что наша речь не зависит от того с кем зачем и где мы говорим...
2
Раздели 54 на две части так,чтобы одна из них была в 8 раз больше другой...
3
Разбери слово стряхнул как часть речи...
3
Длина окружности равна 100, 48 найдите площадь круга ограниченного этой окружностью...
3
30. прочитайте словосочетания. составьте из них предло-жение и запишите его.резвились...
2
Каких значениях параметра a произведение корней уравнения x2−(a+3)x+a2−7=0 на 2...
1
Определите координаты городов москва и самара. определите в каком направлении от...
2
Решите 1.2 и 1.4 с пропорций или x...
1
Что если бы у слона была диффузная нервная сиситема...
3
Кратко написать нужно это(в сокращении крч)задуматься об образовании их сына. знакомый...
2
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
s:=s.Replace('.','').Replace(',','');
s.Println
end.
Пример
> Раз, два, три, четыре, пять. Вышел зайчик погулять.
Раз два три четыре пять Вышел зайчик погулять
Решение, когда разных удаляемых символов может быть много
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
s:=s.Where(с->not(с in [',','.'])).JoinIntoString;
s.Println
end.
program eazy;
var s:string;
i:integer;
begin
writeln('Vvedite tekst');
readln(s);
for i:=length(s) downto 1 do
if (s[i]=' ') or(s[i]=',') or (s[i]='.') then
delete(s,i,1) ;
writeln(s);
end.