Кто смыслит в инфе ! написать программу, позволяющею по последней цифре числа определить последнюю цифру его квадрата. вот примерно я написал, а дальше не ! uses crt; var a,b: integer; begin writeln('bведите a'); readln(a); case b of допишите та буквально 2-3 строки еще без

davidgts davidgts    2   23.06.2019 21:00    1

Ответы
malyshewacarina malyshewacarina  19.07.2020 15:56
Uses crt;
var a,b: integer;
begin
writeln('Bведите a');
readln(a);
b := a mod 10;
b := b * b;
b := b mod 10;
write('Последняя цифра квадрата: ');
writeln(b);
end.

Вариант с CASE:
uses crt;
var a,b: integer;
begin
writeln('Bведите a');
readln(a);
b := a mod 10;
write('Последняя цифра квадрата: ');
case b of
0: writeln(0);
1: writeln(1);
2: writeln(4);
3: writeln(9);
4: writeln(6);
5: writeln(5);
6: writeln(6);
7: writeln(9);
8: writeln(4);
9: writeln(1);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика