Кто сможет с по программированию? напишите программу в паскале для следующей (это 11 класс, тема "массивы"): заполнить массив а[15] числами 106, 112, 118, 124,

ilja2099 ilja2099    2   13.08.2019 12:00    1

Ответы
ohwer ohwer  04.10.2020 15:52
1. Современное решение

// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=106.Step(6).Take(15).ToArray; a.Println
end.

Результат
106 112 118 124 130 136 142 148 154 160 166 172 178 184 190

2. Древнее школьное решение "в лоб"

var
  a:array[1..15] of integer;
  i,k:integer;
begin
  k:=106;
  for i:=1 to 15 do begin
    a[i]:=k;
    k:=k+6;
    Write(a[i],' ')
    end;
  Writeln
end.

3. Усовершенствованное древнее школьное решение.
Последовательность - арифметическая прогрессия с первым членом a₁=106 и разностью d=6.
Тогда a_k=a_1+d(k-1) = 106+6(k-1)=100+6k, k \in [1;15],\mathbb N

var
  a:array[1..15] of integer;
  i:integer;
begin
  for i:=1 to 15 do begin
    a[i]:=100+6*i;
    Write(a[i],' ')
    end;
  Writeln
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика