Кто решит , тому 70 составить программу нахождения суммы чисел , кратных 3 в массиве м [1: 12] (числа вводятся с клавиатуры)

Индира347 Индира347    1   30.06.2019 09:20    2

Ответы
marinaovechkina marinaovechkina  02.10.2020 16:08
Program enot_peredelani;
Var a: array[1..100] of integer;
c,d:integer;
begin
d:=0;
writeln('введите элемент массива');
for c:= 1 to 12 do
begin
readln(a[c]);
if a[c] mod 3 = 0 then 
d:=a[c]+d;
end;
writeln('сумма чисел кратных 3 ==> ',d);
end.
ПОКАЗАТЬ ОТВЕТЫ
kirillan2 kirillan2  02.10.2020 16:08
Const
  n=12;
var
  M:array[1..n] of integer;
  i,s:integer;
begin
  Writeln('Введите ',n,' элементов массива');
  s:=0;
  for i := 1 to n do
  begin Read(M[i]); if M[i] mod 3=0 then s:=s+M[i] end;
  Writeln('Сумма элементов, кратных трем, равна ',s)
end.

Тестовое решение:
Введите 12 элементов массива
32 18 40 52 8 14 28 35 18 21 11 41
Сумма элементов, кратных трем, равна 57
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика