Кто разбирается? короче, такая хрень, ! составьте программу, которая формирует массив из шестнадцати случайных целых чисел от -20 до 20 и: а) находит элементы с нулевыми знаниями; б) находит индексы нечетных элементов; в) подсчитывает количество положительных элементов. -ну? кто тут умный?

Иван199928 Иван199928    3   12.08.2019 03:20    3

Ответы
filimo2000 filimo2000  04.10.2020 12:34
На каком языке программирования?

Паскаль АБС

var
i,count:integer;
a:array [1..16] of integer;
begin
for i:=1 to 16 do begin
a[i]:= Random (-20,20);
end;
for i:=1 to 16 do begin
if (a[i] = 0) then
writeln ('Нулевой элемент ',a [i]);
if (a [i] mod 2 = 1) then
writeln ('Индекс нечетного элемента ',i);
if (a [i] >0) then
inc (count);
end;
writeln ('Количество положительных чисел ',count);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика