Конвертер из числа в дату. Ваша задача — написать программу, которая переводит число во время в читабельном виде.

Пользователь должен ввести число больше 0 и меньше 8639999.

Число необходимо перевести в день, часы, минуты и секунды.

Ну и дополнительной задачей является — забота о выводе.

Слово "день" подбирается на основе кол-ва дней, а часы, минуты и секунды должны заполняться

нулями при одноцифровых значениях.

Пример:

0 -> 0 дней, 00:00:00

224930 -> 2 дня, 14:28:50

466289 -> 5 дней, 09:31:29

8639999 -> 99 дней, 23:59:59

22493 -> 0 дней, 6:14:53

7948799 -> 91 день, 23:59:59

s1656499 s1656499    3   09.08.2022 17:15    0

Ответы
cat0708200416 cat0708200416  09.08.2022 17:16

seconds = int(input())

minutes = 0

hours = 0

days = 0

dayName = str()

zero1 = str()

zero2 = str()

zero3 = str()

while seconds >= 60:

   seconds -= 60

   minutes += 1

while minutes >= 60:

   minutes -= 60

   hours += 1

while hours >= 24:

   hours -= 24

   days +=1

if(seconds / 10 < 1):

   zero3 = str(0)

if(minutes / 10 < 1):

   zero2 = str(0)

if(hours / 10 < 1):

   zero1 = str(0)

if(days % 1 == 1):

   dayName = "день,"

if(days % 10 > 1 and days % 10 < 5):

   dayName = "дня,"

if(days % 10 >= 5 or days == 0):

   dayName = "дней"

print(f"{days} {dayName}, {zero1}{hours}:{zero2}{minutes}:{zero3}{seconds}")

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика