Контрольная работа №3 «Начала программирования» Вариант 1
1. Составьте программу, выводящую значение вещественной
переменной х, равное значению выражения a*b/a+b
где а и - целочисленные переменные, их значения вводятся с клавиатуры.
2. Используя цикл while, напишите программу, вычисляющую
сумму квадратов чисел от 1 до введённого целого числа n.
3.
Запишите значение переменной sum после выполнения фраг-
мента программы.
sum: =0; for i:=5 to 9 do
sum: =sum+i;


Контрольная работа №3 «Начала программирования» Вариант 1 1. Составьте программу, выводящую значение

hakimov676 hakimov676    3   16.05.2021 13:24    111

Ответы
карамелька115 карамелька115  10.01.2024 08:28
1. Для начала нужно составить программу, которая будет высчитывать значение переменной "х" по заданной формуле "a*b/a+b". Для этого нам потребуется ввод значений для переменных "a" и "b" с клавиатуры.

Программа будет выглядеть следующим образом:

```
#include

using namespace std;

int main() {
int a, b;
float x;

cout << "Введите значение переменной 'a': ";
cin >> a;

cout << "Введите значение переменной 'b': ";
cin >> b;

x = (a * b) / (a + b);

cout << "Значение переменной 'x' равно: " << x << endl;

return 0;
}
```

Пояснение:
- Мы объявляем переменные "a" и "b" типа int, так как они целочисленные.
- Затем мы объявляем переменную "x" типа float, так как значение выражения может быть вещественным числом.
- С помощью функции "cout" мы выводим на экран сообщение, просим пользователя ввести значение переменной "a" с помощью функции "cin". Аналогично мы получаем значение для переменной "b".
- Далее мы вычисляем значение переменной "x" по заданной формуле.
- И, наконец, выводим значение переменной "x" на экран с помощью функции "cout".

2. Теперь перейдем к следующему заданию. Нам нужно написать программу, используя цикл while, для вычисления суммы квадратов чисел от 1 до введенного целого числа "n".

Программа будет выглядеть следующим образом:

```
#include

using namespace std;

int main() {
int n, i = 1, sum = 0;

cout << "Введите целое число 'n': ";
cin >> n;

while (i <= n) {
sum += i * i;
i++;
}

cout << "Сумма квадратов чисел от 1 до " << n << " равна: " << sum << endl;

return 0;
}
```

Пояснение:
- Мы объявляем переменные "n", "i" и "sum" типа int. Переменная "n" будет использоваться для хранения введенного пользователем целого числа, "i" - для счетчика в цикле while, "sum" - для суммы квадратов чисел.
- Мы выводим на экран сообщение, просим пользователя ввести целое число "n" с помощью функции "cin".
- Далее инициализируем переменную "i" значением 1 и переменную "sum" значением 0.
- Далее, пока значение "i" не превысит значение "n", мы будем выполнять следующие действия в цикле while:
- К каждой итерации цикла прибавляем к "sum" значение "i" в квадрате (i * i).
- Увеличиваем значение "i" на 1.
- После выполнения цикла мы выводим на экран сообщение с результатом - суммой квадратов чисел от 1 до "n".

3. И, наконец, мы должны записать значение переменной "sum" после выполнения фрагмента программы:

```
sum = 0;
for (int i = 5; i <= 9; i++) {
sum += i;
}

```

Пояснение:
- Мы объявляем переменную "sum" типа int и инициализируем ее нулевым значением.
- Затем мы выполняем цикл for со счетчиком "i", который начинается с значения 5 и выполняется, пока значение "i" меньше или равно 9.
- На каждой итерации цикла мы прибавляем значение "i" к переменной "sum".
- После завершения цикла, значение переменной "sum" будет равно сумме чисел от 5 до 9 (5 + 6 + 7 + 8 + 9), то есть 35.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика