класс.
Python.
Дан массив, содержащий 8 положительных целых чисел, не превышающих 1000
Необходимо найти в этом массиве количество двузначных элементов, которые кратны числу 5,
и заменить каждый из таких элементов на это количество. Напишите программу для решения
этой задачи. В качестве результата программа должна вывести изменённый массив, по одному
элементу в строке.
Язык программирования Python.

tolodono tolodono    3   28.04.2020 17:16    15

Ответы
liker27 liker27  04.08.2020 01:26

n = int(input())

#Сколько чисел

value = []

z = 0

for i in range(n):

   t = int(input())

   value.append(t)

   if t // 100 == 0 and t % 5 == 0:

       z += 1

for i in value:

   if i // 100 == 0 and i % 5 == 0:

       g = value.index(i)

       value.remove(i)

       value.insert(g, z)

for i in value:

   print(i)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика