Как составить программу, которая подсчитывает сумму отрицательных чисел (s) и произведение положительных

kostaKOSTAkosta kostaKOSTAkosta    3   13.08.2019 07:10    4

Ответы
dencommission dencommission  02.08.2020 14:53
const   N = 5;  
var   a, S1, S2: Integer;  
i, Q1, Q2: Byte;  
begin  
S1 := 0; Q1 := 0;  
S2 := 0; Q2 := 0;  
writeln('Введите ', N, ' чисел:');  
for i := 1 to N do
begin    
read(a);    
if a < 0 then
begin      
S1 := S1 + a;      
inc(Q1)    
end;    
if a > 0 then
begin      
S2 := S2 + a;      
inc(Q2)    
end;  
end;  
writeln;  
if Q1 > 0 then
begin    
writeln('Сумма отрицательных чисел: ', S1);    
writeln('Количество отрицательных: ', Q1)  
end  
else
writeln('Отрицательных нет');  
if Q2 > 0 then
begin    
writeln('Сумма положительных чисел: ', S2);    
writeln('Количество положительных: ', Q2)  
end  
else
writeln('Положительных нет')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика