tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Как написать программу в паскале,
Как написать программу в паскале, чтобы 2 рандомных числа не повторялось?
alishraup
3 03.08.2019 05:30
3
Ответы
Asaboc453
30.09.2020 07:39
Var a,b,n:integer;
begin
n:=10;
Randomize;
a:=random(n)+1;
b:=random(n)+1;
while b=a do b:=random(n)+1;
writeln('a = ',a,' b = ',b);
end.
Пример:
a = 8 b = 4
ПОКАЗАТЬ ОТВЕТЫ
ann0706kol
30.09.2020 07:39
{
Думаю, это должно работать
Важно, что во второй раз выбор происходит уже среди n-1 вариантов
}
const n = 10;
var i,j: integer;
begin
i := 1 + random(n);
j := 1 + random(n-1);
if j >= i then j := j + 1;
write(i,' ',j)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
f79gkr4st
04.03.2021 20:14
Среди приведённых ниже 3 чисел записанных в различных системах счисления найдите максимальное и запишите его в ответе в десятичной системе счисления. 36 (в 8 сист.счисл.)1D (в 16...
Zenkinadasha
18.03.2021 19:54
На Python нужно сделать: Напишите программу, которая получает с клавиатуры трёхзначное число. В результате работы программа выводит на экран все числа (каждое на новой строке), которые...
dima2727
24.11.2021 19:58
Напишите программу на паскале: Сгенерируйте целочисленный массив из 20 элементов случайным образом в диапозоне от -15 до 15. Посчитайте сумму элементов которые больше 9; Посчитайте...
Незнайкаа11
24.11.2021 19:58
Вопросы для размышления 1. Как можно создавать модели в программе SketchUp? 2. Каковы функции инструментов управления пространством в про- грaммe SketchUp? 3. Для выполнения каких...
kiryanova1969
11.06.2019 07:40
Документ (без упаковки) можно передать по каналу связи с одного компьютера на другой за 75 секунд. если предварительно упаковать документ архиватором, передать упакованный документ,...
мага7626
09.09.2019 08:10
Программирование 98 , паскаль/c++/в крайнем случае python 1.в постфиксной записи (или обратной польской записи) операция записывается после двух операндов. например, сумма двух чисел...
maksikus1
08.05.2021 07:12
Как модуль PyGame устанавливается в Windows 10?...
samsungtaba32
08.05.2021 07:12
Условие задания. На нагревание кирпича массой 4,7 кг на 14°C затрачено такое же количество теплоты, как и для нагревания4,7 кг воды на 2,9°С. Определи удельную теплоёмкость кирпича....
tikatS66
08.05.2021 07:11
Прямоугольный параллелепипед (куб) и его развертка. Урок 1 Найди площадь поверхности куба, если ребро равно 2,5 см. ответ: см2....
oladushek2002oy6bqn
08.05.2021 07:11
Задание 2. Выполните обозначенные цифрами в тексте из задания 1 языковые разборы: (2) — морфемный и словообразовательный разборы слова; ( ) (3) — морфологический разбор слова; ( )...
Популярные вопросы
Составить 8 предложений у прилагательных подписать разряды...
3
Выпиши из учебника признаки,свойственные предпринимательской деятельности,объясни...
1
(№ 29 (- выберите один вариант ответа) заполните пропуск a helps people in hospital....
2
Sin 90 градусов с каким знаком: + или - ?...
3
Гелій масою 1,1 кг ізобарно нагріли на 23 к.знайти роботу виконану газом,зміну...
3
Написать формулы солей гидросульфид железа 3 гидрокарбонат ca2 попогите...
1
ответьте на вопросы: 1) причины победы в великой отечественной войне 2) итоги и...
1
Ящик массой 25 кг подняли вверх на веревке при этом совершили работу 2,25кдж на...
2
5.underline the correct them 1)what time did you left/leave for school this morning?...
2
Водень масою 66 г ізобарно нагріли на 238 к. знайти роботу виконану газом, зміну...
2
begin
n:=10;
Randomize;
a:=random(n)+1;
b:=random(n)+1;
while b=a do b:=random(n)+1;
writeln('a = ',a,' b = ',b);
end.
Пример:
a = 8 b = 4
Думаю, это должно работать
Важно, что во второй раз выбор происходит уже среди n-1 вариантов
}
const n = 10;
var i,j: integer;
begin
i := 1 + random(n);
j := 1 + random(n-1);
if j >= i then j := j + 1;
write(i,' ',j)
end.